Talk:Conway's Game of Life: Difference between revisions

(→‎Java Swing: Sub-page?)
Line 14:
 
== Java Swing ==
My Swing implementation is kind of long (because it's a swing implementation). If anyone finds it inappropriately long, we can discuss removing it.--[[User:Burke9077|Burke9077]] ([[User talk:Burke9077|talk]]) 17:34, 17 January 2014 (UTC)
 
: I've not got a problem with having it, but the code could be better. :-) For example, it's more idiomatic to not make <code>GameBoard</code> implement interfaces like <code>ComponentListener</code> and to instead pass in a inner subclass of <code>ComponentAdapter</code>. Similarly, you've got a big <code>if</code> chain inside <code>actionPerformed</code> (in <code>ConwaysGameOfLife</code>) whereas it is better to use some inner classes that are specific to each event source. You should separate the model from the GUI too (turning everything between a list of points and an array of values every turn has got to be less than perfectly efficient). All criticism offered in the spirit of trying to help you make your code be more idiomatic (my watchword for what makes a good RC example).
Line 20:
 
You could move it to a sub-page referenced from the task page like what is done here: [[Formal_power_series#Java|Formal_power_series#Java]]. --[[User:Paddy3118|Paddy3118]] ([[User talk:Paddy3118|talk]]) 12:00, 17 January 2014 (UTC)
 
Thanks for the advice Donal, I will move the actions that I can to annon innerclasses. I think I will take your advice Paddy3118, I removed a lot of commenting when I posted it here, so I could restore that in a separate page.--[[User:Burke9077|Burke9077]] ([[User talk:Burke9077|talk]]) 17:34, 17 January 2014 (UTC)
Anonymous user